Tutoriale

Sfaturi utile pentru utilizatorii de echipamente Mikrotik

Sfaturi utile pentru tine depre Mikrotik – Partea

Sunt multe de spus despre MikroTik, mai ales atunci cand cauzit solutii cat mai neordinare. In acest articol mă voi împărtăși cu câteva opțiuni și adaptări pentru RouterBoard din seria RB9xx.

  • Automatizarea upgrade/update RouterOS, înștiințarea pe email sau SMS.
  • Clonarea automată a dispozitivelor, prin copierea scriptului configurației.
  • Blocarea traficului și trimiterea printr-un alt gateway.

Partea 1 – Automatizarea upgrade/update RouterOS.

Trimiterea mesajelor informative prin SMS și email.

Release pentru Mikrotik este elaborat continuu de companie, iar în fiecare versiunea nouă se pot întâlni mai multe sau mai puține modificări noi, corecții sau implementări noi. Nu este deajuns să facem update la RouterOS, este obligatori să ținem la zi și FW.  Să pierzi timpul urmărind actualiările nu este preaa interesant.

Vom urmări un caz în care folosim RouterBoard RB952Ui-5ac2nD. Echipamentele sunt aplasate în diferite orașe, iar conexiunile cu sediul central sunt asigurate prin VPN. Lucru cunoscut, nu?

Routerul central am ales un CCR1009-8g-1S, un model  mai vechi de vreo 3 ani deja, toate celelalte routere sunt la fel adică folosesc platforma MIPSBE, înseamnă că vom folosi aceleași pachete. Aceste routere vor lua pachetele de pe routerul central (CCR1009).

Este un moment important. Pachetele descarcate vor fi stocate în folderul rădăcină. Iar după repornire ele vor fi șterese. Acest lucru este critic pentru ca dacă vom pune pachetele mipsbe pentru CCR ar fi fi o problemă dacă cumva routerul nostru va reboota singur. În așa fel noi vom stoca aceste fișiere într-un directoriu separat.

Ce avem nevoie ?

Avem nevoie ca serverul FTP să fie pornit. Opțional de setat Email și SMS.

Pentru echipamentul central vom folosi un script.

Vezi scriptul mai jos:

:local email „email”
:local user „user”
:local pass „password”
:local folder „folder”
:local phone „Phone number +” #####
:if ( [/system package update get status] != „Downloaded, please reboot router to upgrade it” ) do={ /system package update checkfor-updates
:delay
:if ( [/system package update get installed-version] != [/system package update get latest-version] ) do={ /system package update download
:delay 20
:foreach i in=[/file find where packageversion=[/system package update get latest-version]] do={ /tool fetch address=127.0.0.1 src-path=„$[/file get number=”$i” name]” dst-path=„$folder/$[/file get number=”$i” name]” user=$user password=$pass mode=ftp }
/tool e-mail send to=$email subject=„Update Mikrotik” body=„Disponibilă o nouă versiune RouterOS! Versiune – $[/system package update get latest-version]. Ce este nou – http://www.mikrotik.com/download” /tool sms send usb1 channel=2 „$phone” message=„New RouterOS version is available!” } }

 

În funcție de viteza de acces la routere trebuie setat delay corespunzător. :delay 20.

Pentru client este necesar două scripturi.

  1. Setarea master

    /system upgrade upgrade-package-source add address=xxx.xxx.xxx.xxx user=user

  2. Script update

    /system upgrade refresh :delay 5 /system upgrade download-all reboot-after-download=yes

  3. Script update firmware

    :if ( [/system routerboard get current-firmware] < [/system routerboard get upgrade-firmware] ) do {
    /system routerboard upgrade
    /system reboot }

Lasă un răspuns

Adresa ta de email nu va fi publicată. Câmpurile obligatorii sunt marcate cu *