Academia MikroTik România este partener autorizat MikroTik

Când am avut nevoie să-mi dau seama cum să fac failover sau loadbalancing, având două sau mai multe canale în internet. Am găsit multe articole și instrucțiuni care descriu configurațiile de lucru. Dar aproape peste tot nu am găsit o explicație despre cum funcționează totul și descrieri ale diferențelor dintre diversele opțiuni. Vreau să corectez această nedreptate și să colectez cele mai simple opțiuni pentru crearea configurațiilor de failover și failover într-un articol.

Deci, avem un router care conectează rețeaua noastră locală și două canale la Internet (ISP1 principal și ISP2 de rezervă).
Să vedem ce putem face:
Trebuie să vă avertizez: în ciuda faptului că în acest articol voi descrie totul pentru mikrotik, nu voi atinge subiectul scripting.

Failover

blank


Cel mai simplu failover poate fi configurat folosind prioritatea rutei (distanță pentru mikrotik / cisco, metric în linux / windows), precum și mecanismul de accesibilitate a gateway-ului de verificare (check gateway).

În configurația de mai jos, tot traficul de internet implicit trece prin 10.100.1.254 (ISP1). Dar imediat ce adresa 10.100.1.254 devine indisponibilă (iar ruta prin ea este inactivă) – traficul va trece prin 10.200.1.254 (ISP2).

# Setam adresele IP de conectare la ISP:
/ip address add address=10.100.1.1/24 interface=ISP1
/ip address add address=10.200.1.1/24 interface=ISP2
# Setam adesa IP pentru LAN
/ip address add address=10.1.1.1/24 interface=LAN
# Configuram NAT
/ip firewall nat add src-address=10.1.1.0/24 action=masquerade chain=srcnat
#Asiguram canalele de rezerva prin configurarea distance =2 pentru canalele de rezerva
/ip route add dst-address=0.0.0.0/0 gateway=10.100.1.254 distance=1 check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=10.200.1.254 distance=2 check-gateway=ping

Check-gateway=ping – transimte fiecare 10 sec cate 1 pachet ping dupa doua esuari seteaza gateway inactiv.

Cunosc două opțiuni pentru rezolvarea acestei probleme de inginerie. Primul și cel mai obișnuit este să folosești scripturi. Dar din moment ce nu atingem scripturile din acest articol, vom folosi pe al doilea. Aceasta implică utilizarea nu tocmai corectă a parametrului de aplicare. Dar ne va ajuta să analizăm canalul furnizorului mai adânc decât la gateway.
Principiul este simplu:
În locul tradiționalului gateway implicit = gateway provider, vom spune routerului că gateway-ul implicit este unul dintre nodurile mereu disponibile. De exemplu, 8.8.8.8 sau 8.8.4.4 și, la rândul său, este accesibil prin gateway-ul furnizorului.

# Setam adrese IP:
/ip address add address=10.100.1.1/24 interface=ISP1
/ip address add address=10.200.1.1/24 interface=ISP2
# LAN 
/ip address add address=10.1.1.1/24 interface=LAN
# NAT
/ip firewall nat add src-address=10.1.1.0/24 action=masquerade chain=srcnat
/ip route add dst-address=8.8.8.8 gateway=10.100.1.254 scope=10
/ip route add dst-address=8.8.4.4 gateway=10.200.1.254 scope=10
# Setam gateway recursiv
/ip route add dst-address=0.0.0.0/0 gateway=8.8.8.8 distance=1 check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=8.8.4.4 distance=2 check-gateway=ping

Acum aruncăm o privire la ce se întâmplă mai detaliat:
Trucul este că portalul furnizorului nu știe că 8.8.8.8 sau 8.8.4.4 este un router. El va direcționa traficul pe calea obișnuită.
Mikrotik-ul nostru consideră că, în mod implicit, tot traficul de internet ar trebui trimis la 8.8.8.8. Care nu este direct vizibil, dar este disponibil prin 10.100.1.254. Și dacă ping-ul din 8.8.8.8 va disparea, atunci mikrotik va începe să trimită tot traficul pe Internet la 8.8.4.4. Sau mai degrabă către 10.200.1.254 (ISP2) definit recursiv.

Dar, de câteva ori am avut o situație în care internetul funcționează prin gateway de acces a furnizorului..Dar nu există o gazdă sau rețea specifică. În astfel de cazuri, metoda de mai sus nu ajută prea mult. Iar pentru a asigura funcționarea fără probleme, a trebuit să verific disponibilitatea nodului folosind scripturi.

Mai multe pe wiki.mikrotik.com sau la cursurile organizate de Academia Mikrotik. Înregistrare imediată.

error: Te aspteptam la cursurile noastre!